
DEFINITION OF TERMS


PRIVATE 

Notes:
1.
Use entries designated user term in application windows and in information about windows, such as messages, help, and documentation.  Do not use synonyms for these terms.

2.
The definitions contain cross-reference information to bridge programmer and user terms.  Terms necessary for application developers and terms useful to users are not always the same.  The Common User Access assists application developers as they design useful application interfaces.  However, the terms in these definitions describing CUA must also be meaningful to application developers.  When a user term differs from a programming term, the definition for the user term will identify the programming term.  The opposite is also true.

3.
Some definitions contain words or phrases for which definitions also appear herein.  Where this may lead to confusion, such words or phrases are shown in italics.

4.
Items with initial caps are screen elements, such as choices from menus or lists.

1
PRIVATE 

About....(user term) A help action that displays the logo window of the application.

accelerator  A key or combination of keys that invokes an application-defined function.  The user term is function key.
action  (user term) One of the defined tasks that an application performs.  Actions modify the properties of an object or manipulate the object in some way.

action bar  (user term) They are at the top of the primary window that contains keywords that give users access to actions available in the window.  After users select a choice in the action bar, a pull-down extension appears from the action bar.  The programmer term is menu bar.

action bar pull-down  (user term) An extension of the action bar that displays a list of choices available for a selected choice in the action bar.  After users select a choice in the action bar, the pull-down appears.  Additional pop-up windows can appear from pull-down choices.  The programmer terms is menu.

action message  (user term) A message box that tells users that an exception condition has occurred.  Users must perform an action to correct the situation.  Compare with information message and warning message.

active window  (user term) The window that users are currently interacting with.  This is the window that receives keyboard input.  Contrast with inactive window.

aligned  Arranged in a column in which all values either start in the same position (left-aligned) or end in the same position (right-aligned).

anchor point  The position or choice from which the selection or de-selection is intended.

application  (user term) A collection of software components that users buy and install to perform specific types of work on a computer.

application icon  (user term) A unique icon that represents the application when it is minimized (for "graphics windowing" environments only).

application object  A form that is provided by the application for users.  A spreadsheet form is an example of an application object.  Contrast with user object.

application option  A choice programmers may implement in their application.  If they decide to implement an option, they must do so as described in this book.  Compare with user option.

Apply  A standard pushbutton that causes the application to accept any user changes in dialogs that set properties but does not close the dialog box.

auto tab  An application option that automatically moves the text cursor to the next entry field after users type into the last character position of an entry field (Auto-return in DataFlex).

available choice  (user term) An item that the current state of the application allows users to select.  Contrast with unavailable choice.

backspace  (user term) A typing action that deletes the selection if one exists.  If there is no selection, backspace deletes the character to the left of the cursor.

backtab  (user term) A typing action that moves the cursor to the beginning of the previous entry field or the previous selection field if no choice is selected.  If the previous selection field has a choice selected, the cursor moves to the selected choice.  The cursor moves from right to left and bottom to top.  At the top-leftmost field, the cursor moves to the bottom-rightmost field.  The cursor moves differently within a multiple-line entry field that is the only field in a window.  Contrast with tab.

beginning of data  (user term) A cursor-movement function that moves the selection cursor to the leftmost position in the current field.  Your application defines where the beginning of the data is and provides scrolling as required.

beginning of line  (user term) A cursor-movement function that moves the selection cursor to the leftmost choice.  Your application defines the leftmost position.

border  (user term) A visual indication of the boundaries of a window.

Cancel  (user term) A standard pushbutton that removes the active dialog box without performing any uncommitted changes and returns the dialog to the window that preceded it.  Can be used in conjunction with Retry in device error messages.  See close.  Contrast with exit.

cascading pull-down  A pull-down that is invoked from another pull-down.

Cascade  (user term) An optional choice in the Window pull-down of multiple-document interface applications.  It arranges the secondary windows and icons so that each window is offset on two sides from the window it overlaps.  The windows appear like index cards stacked one behind the other.

check box  (user term) A control that consists of a square box and choice text.  It acts like a switch.  An "X" appears in the check box to show a choice is selected.  Check boxes can be used alone or grouped in related sets so users can choose one or more choices.

check mark  (user term) A user-interface component that appears as [X].  It is used in check boxes and pull-downs to tell users which choice is currently in effect (the current state).

choice  (user term) An item that users may select.  Choices appear in selection fields, action bars, and action bar pull-downs.  Text, bit maps, and icons can be used for choices (text only in DataFlex).

Clear  (user term) An optional choice in the Edit pull-down that removes a selected portion from the object without copying it to the clipboard.  The space is not compressed.  Contrast with delete.

click  (user term) To press and release a mouse button without moving the mouse pointer off the choice.  Compare with direct manipulation, double-click, and drag select.

client area  The part of the window inside the border that is below the action bar.  It is the users' workspace, where users type information and choose selections from selection fields.  In primary windows, it is where you present to users the object they want to work on.

clip  To truncate information by removing those parts of a displayed image that lie outside a given boundary.

clipboard  (user term) An area of storage that can hold data.  Data in the clipboard is available to other applications.

column heading  (user term) One or more words at the top of a column of information that identify the information in that column.

combination box  A control that combines the capabilities of an entry field and a list box.  The list box contains scrollable choices that users can select to complete the entry field.  Compare with drop-down combination box and list box.

common action  One of a set of actions that has common meaning across all applications.  Examples are help, exit, and cancel.

contextual help  (user term) A help action that provides specific information about the item the cursor is on.  This help action is contextual because it provides information about a specific item as it is currently used.  The information provided is specific to the meaning of the item within the work session.  Also known as field-level help.  Contrast with extended help.

control  A user-interface component that allows users to select choices or type information.  Check box, radio button, and entry field are examples of controls.

Copy  (user term) A choice in the Edit pull-down that produces a duplicate of the selected portion of an object on the clipboard without removing the selection portion from the object.

current state  Whether or not a specific choice is active.  A current state indicator shows users when a specific choice is active.

current state emphasis  A visual cue that shows users that a specific choice is active.  An example is the check mark that is used in action bar pull-downs.

cursor  (user term) A visual cue that shows users the current position of the keyboard input focus.  The keyboard cursors are the selection cursor and the text cursor.

cursored emphasis  (user term) A visual cue in the form of a highlight bar that shows users that the cursor is on a selection choice.

cursored and selected emphasis  A visual cue in the form of a highlight bar that shows users that a choice has been selected and that the cursor is still on the selected choice.

Cut  (user term) A choice in the Edit pull-down that removes a selected portion from an object and copies it to the clipboard.

data field  An area that users type information into.  The user term is entry field.

Delete  (user term) An optional choice in the Edit pull-down that removes the selected portion from the object without copying it to the clipboard.  The space is compressed.  Contrast with clear.

dialog  The interaction between users and the computer.

dialog box  A movable window, fixed in size, in which users use controls to provide information that is required by an application so it can continue a user request.  The user term is pop-up window.  Compare with primary window, secondary window, and message box.

direct manipulation  The use of a pointing device to immediately perform actions on objects.  Compare with click, double click, and drag select.

double-click  (user term) To press and release a mouse button within a user-defined time limit without moving the mouse pointer off the choice.  Compare with click, direct manipulation, and drag select.

drag select  (user term) To press a mouse button and hold it down while moving the mouse pointer so that the pointer travels to a different location on the screen.  Dragging ends when the mouse button is released.  All items between the button down and button up points are selected.  Compare with click, double-click, and direct manipulation.

drop-down combination box  A variation of a combination box in which a list box is hidden until users take an explicit action to make it visible.  See combination box and list box.  Compare with drop-down combination box.

Edit  (user term) A standard choice in the action bar that enables users to modify original documents and create new documents.  It is used with the clipboard.

emphasis  Highlighting, color change, or other visual indicators that serve as visual cues to users.  For example, a choice can be highlighted to show users that that choice has been selected.

end of data  (user term) A cursor-movement function that moves the selection cursor to the rightmost position in the current field.  Your application defines where the end of the data is and provides scrolling as required.

end of line  (user term) A cursor-movement function that moves the selection cursor to the rightmost choice.  Your application defines the rightmost position.

enter  (user term) A common action that submits information to the computer for processing.  Enter tells the computer to perform selected actions on selected objects.  Remember that select means to mark a choice; enter means to send all designated choices to the computer for processing.  Enter also refers to the enter key, which takes you to the next logical stop in your application.  Enter works differently in multiple-line entry fields.

entry field  (user term) A control that users type information into.  It usually has its boundaries indicated.  See single-line entry field and multiple-line entry field.  Compare with selection field.

Exit  (user term) An optional common action that ends the active application and removes all windows associated with it.  Requires a message box if information could be lost.  See close.  Contrast with cancel.

explicit selection  A selection technique whereby users cursor to a choice and press the Spacebar to select that choice.  Compare with implicit selection.

Extended help  (user term) A choice in the Help pull-down that provides information about the contents of the application window from which users requested help.  Also known as general help.  Contrast with contextual help.

extended selection  A selection technique that allows users to select one or more choices.  Compare with single selection.

field prompt  Descriptive, static text that identifies a selection field or entry field.

File  (user term) A standard choice in the action bar that enables users to work with files.

function key  (user term) A key that causes a specified sequence of operations to be performed when it is pressed.  The programmer term is accelerator.

graying  The indication that a choice in a pull-down is unavailable.  For black choices, it is accomplished by reducing the contrast between the choice and its background.  See unavailable emphasis.

group box  A rectangular frame with a title used to group related choices.

group heading  (user term) Word or words that identify a group of related fields.

Help  (user term) A standard pushbutton that provides information about the item the cursor is on or about the entire dialog box.

Help for help  (user term) A choice in the Help pull-down that provides information to users about how the help facility works.

Help index  (user term) A choice in the Help pull-down that provides an index with search capability of all the help information in the application.

help window  (user term) A window that contains information to assist users.

icon  (user term) A pictorial representation of an object or a selection choice.  Icons can represent objects that users want to work on or actions that users want to perform.  A unique icon also represents the application when it is minimized.  Icons are not used in DataFlex.

implicit selection  A selection technique whereby users cursor to a choice and it is automatically selected.  Compare with explicit selection.

inactive window  (user term) A window that users are not currently interacting with.  This window cannot receive keyboard input.  Contrast with active window.

information message  (user term) A message box that tells users that a function is performing normally or has performed normally.  User acknowledgement may or may not be required, depending on the message.  Compare with action message and warning message.

initial value  (user term) Information in an entry field that is provided by an application when an entry field is first displayed.  An initial field value can be a partial entry, such as the first few digits of a purchase order number, or a complete entry, such as a person's full name.  Compare with preselected choice.

input focus  The area of a window where user interaction is possible from either the keyboard or mouse.

insert mode  (user term) An entry mode obtained by pressing the insert (Ins) key.  This mode inserts characters where the text cursor is positioned.  Text to the right is shifted to the right.  Contrast with replace mode.

inverse color highlighting  A screen emphasis feature that changes both the foreground and background color of an item.  This highlighting is often used as selected emphasis for choice text.

Keys help  (user term) A choice in the Help pull-down that provides a listing of an application's keys and their assigned functions.

left-aligned  See aligned.

list box  A control that contains scrollable choices from which users can select one choice.  The user term is selection list.  Compare with combination box and drop-down combination box.

logo window  A modal dialog box containing the application copyright notice and other information that identifies the application.

menu  An extension of the menu bar that displays a list of choices available for a selected choice in the menu bar.  After users select a choice in the menu bar, the menu appears.  Additional pop-up windows can appear from menu choices.  The user term is action bar pull-down.

menu bar  The area at the top of the primary window that contains keywords that give users access to actions available in that window.  After users select a choice in the menu bar, the menu appears.  The user term is action bar.

message  (user term) Information not requested by users but shown by the application in response to user action or an internal process.  Application messages about status, problems, or user actions should be distinguished from a "message" or note sent to users by other users.  See action message, information message, and warning message.

message box  (user term) A type of window that shows messages to users.  Compare with primary window, dialog box, and secondary window.

mnemonic  A single designated character within the text of a choice identified by an underscore beneath the character.  When users type the mnemonic for a choice, that choice is selected.  See mnemonic selection.

mnemonic selection  A selection technique that allows users to type the mnemonic for a choice to select that choice.

modal dialog box  A type of dialog box that requires that users complete the dialog box before continuing to work in the application window from which the dialog box was displayed.  The user term is pop-up window.  Contrast with modeless dialog box.

modeless dialog box  A type of dialog box that allows users to interact with application windows outside the dialog box without first completing the dialog box.  The user term is pop-up window.  Contrast with modal dialog box.

mouse button  (user term) A mechanism on a mouse used to select choices or initiate actions.  For example, the mouse button is used to mark or select a choice.

multiple-documented interface  An interface style that allows users to view many objects at the same time or the same object many times within one primary window.

multiple-line entry field  A control into which users type information that consists of more that one line.  A panel with multiple check boxes, for example.  Compare with  single-line entry filed.

navigation  The movement of the cursor around the screen using a pointing device or the keyboard.  The user interface defines the mouse and key assignments for navigation.

New  (user term) A choice in the file pull-down that allows users to create a new file or object.

No  A standard pushbutton used in messages to provide a negative response to a question.

object  Anything users can manipulate as a single unit.  Objects are the focus of the users' attention.

object-action  A process sequence in which users select an object and then select an action to apply to that object.

OK  A standard pushbutton that causes the application to accept any changed information and closes the dialog box.

Open  (user term) A choice in the File pull-down that reads an existing file and displays it for users.

options  (user term) A standard choice in the action bar that allows users to customize the application object.  See also application option and user option.

page down  A scrolling action that displays information below the currently visible window area.

page left  (user term) A scrolling action that displays information to the left of the currently visible in a window.

page right  (user term) A scrolling action that displays information to the right of the currently visible area.

page up  A scrolling action that displays information above the currently visible area.

Paste  (user term) A choice in the edit pull-down that copies the contents of the clipboard into an object at a selected location.

pointer  (user term) The symbol displayed on the screen that is moved by a pointing device, such as a mouse.  It is used to point at the objects and actions users want to select.

pointing device  (user term) An instrument, such as a mouse, trackball, or joystick, used to move a pointer on the screen.

pop-up window  (user term) A movable window, fixed in size, in which users provide information that is required by an application so it can continue a user request.  The programmer term is dialog box.

preselected choice  (user term) A highlighted and selected choice that is provided by an application when a selection field is first displayed.  It allows users to proceed immediately to the next field if this choice is the users' choice.  Compare with initial value.

Print  (user term) A choice in the File pull-down that prepares a file for the print and schedules it to be printed.

progress indicator  A modal dialog box containing specific user-interface components which shows users the status of user requests that are complex and may take a long time for the computer to complete.

property  Unique characteristic of an object that can be modified.  The properties of an object describe the object.  Type style is an example of a property.

pull-down  (user term) See action bar pull-down.

pushbutton  (user term) A rounded-corner rectangle (or <Darts> in DataFlex) with text inside.  Pushbuttons are used in dialog boxes for actions that occur immediately when the pushbutton is selected.

radio button  (user term) A control that consists of a circle and choice text.  Radio buttons are combined to show users a fixed set of choices that are mutually exclusive.  These fields must contain at least two choices, one of which is usually selected.  The circle is partially filled in when a choice is selected.

replace mode  (user term) An entry mode obtained by pressing the insert (Ins) key.  Selected text is deleted and typed characters are inserted in its place.  In replace mode, at least one character is always selected.  Contrast with insert mode.

Reset  A standard pushbutton that cancels any user changes that have not been submitted to the application.  It resets any changed fields to their initial values and displays them in the dialog box.

right-aligned  See aligned.

Save  (user term) A choice in the file pull-down that writes an existing file into a storage device, such as a disk or diskette.

Save as...  (user term) A choice in the file pull-down that writes the existing file into a new file without changing the original.

screen  (user term) The physical surface of a work-station upon which information is shown to users.

scroll bar  (user term) A window component associated with a scrollable area that provides users a visual cue that more information is available and that the unseen information can be manipulated into view using the mouse.  Users scroll the information in the window by interacting with the scroll bar.

scrollable entry field  An entry field larger than the visible field.  The user term is entry field.

scrolling action  A function that enables users to control the information visible in a window.  Scrolling actions are: page up, page down, page left, and page right.

scrolling increment  (user term) The fixed amount of information that scrolls, as determined by an application.

secondary window  (user term) A type of window that is movable and sizable and is always associated with a primary window.  Just as a primary window carries out the primary dialog, a secondary window carries out a modeless, parallel dialog.  Help is an example of a parallel dialog that may appear in a secondary window.  Compare with primary window, dialog, and message box.

select  (user term) To mark or choose an item.  Remember that select means to mark a choice; enter means to send all selected choices to the computer for processing.

selected emphasis  A visual cue that shows users that a choice is currently selected.  Inverse color is an example of selected emphasis.  See also Inverse color.

selection cursor (user term) A visual cue whereby users indicate with the keyboard the choice they want to interact with.  It is represented by highlighting the choice with an inverse bar.  Compare with text cursor.

selection field  (user term) A set of related choices that are presented to users.  Compare with entry field.

selection indicator  A visual cue that shows users that a choice has been selected.  An example is the "X" in a check box.

selection list  (user term) A control that contains scrollable choices from which users can select one choice.  Programmer term is list box.

separator  A line or color boundary that provides users a visual distinction between two adjacent areas.

single selection  A selection technique that allows users to select only one choice.  Compare with extended selection.

single-line entry field  A control into which users type information that is limited to one line.  Compare with multiple-line entry field.

standard action bar choices  The choices File, Edit, View, Options, and Help.

Stop  A standard pushbutton used in a progress indicator to cancel the current operation at the next non-destructive breaking point.

supplemental windows  Windows that enable applications to extend the dialog with users.  The two supplemental windows are secondary windows and dialog boxes.  See secondary windows and dialog boxes.  Contrast with primary window.

switch to action bar  (user term) An action that moves the cursor to the action bar.

tab  (user term) A typing action that moves the cursor to the beginning of the next entry field or the next selection field if no choice is selected.  If the next selection field has a choice selected, the cursor moves to the selected choice.  The cursor moves from left to right and top to bottom.  At the bottom-rightmost field, the cursor moves to the top-leftmost field.  The cursor moves differently within a multiple-line entry field that is the only field in a window.  Contrast with backtab.

text cursor  (user term) A symbol displayed in an entry field that shows users where typed input will appear.  Compare with selection cursor.

Tutorial  (user term) An optional choice in the Help pull-down that provides access from the current window to a tutorial if the application has one.

unavailable choice  (user term) An item that the current state of the application does not allow users to select because of some condition in the application.  Contrast with available choice.

unavailable emphasis  A visual cue that shows users which items in a list of choices are currently unavailable for selection.  See graying.

Undo  (user term) A choice in the Edit pull-down that reverses the action of the most recently executed user action (application dependent).

user object  The information created by users within an application.  Contrast with application object.

user option  A choice of appearance or interaction characteristics that programmers give users during the operation of an application.  Compare with application option.

value set  (user term) A control provided by an application that allows users to select one choice from a number of choices.  It is usually used to present graphic choices to users.

View  (user term) A standard choice in the action bar that allows users to select different ways to look at an object without affecting the object itself.

warning message  (user term) A message box that tells users that a potentially undesirable situation could occur.  Users only need to respond to the message to continue.  Corrective action may be required later to avoid an error situation.  Compare with action message and information message.

window  (user term) 1. An area of the screen with visible boundaries through which information is displayed.  A window can be smaller than or equal in size to the screen.  Windows can overlap on the screen and give the appearance of one window being on top of another.  2. Window.  A choice in the action bar of multiple-document interface applications.

window component  The smallest named visual parts of a window, such as the action bar, and scroll bar.

window title  The area that contains the application name and the file name, if applicable.  This area is emphasized to tell users when the window is active.

Yes  A standard pushbutton used in messages to provide a positive response to a question.
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